iT邦幫忙

0

關於wampServer裡的資料庫

請問各位大大,在編輯connect.php(如下圖)
https://ithelp.ithome.com.tw/upload/images/20180912/20105503zWQ7WMwMHL.jpg
一直出現該錯誤↓↓
https://ithelp.ithome.com.tw/upload/images/20180912/20105503V0R978gSOK.jpg

我已將sql檔案匯入phpMyAdmin的MySQL及MariaDB都有匯入資料↓↓
https://ithelp.ithome.com.tw/upload/images/20180912/20105503payLL8gCN8.jpg
https://ithelp.ithome.com.tw/upload/images/20180912/20105503Ouc910AvQT.jpg

請問何處編寫有錯,導至我無法連結資料庫

看更多先前的討論...收起先前的討論...
柯柯 iT邦新手 5 級 ‧ 2018-09-12 13:48:59 檢舉
PHP版本是7的話
PHP7 不支援mysql 換用mysqli吧 ~
現在都不推薦用mysql_connect了
用PDO 或 mysqli 吧
你說的意思是要下載mysqli orPDO嗎?然後在匯入!
柯柯 iT邦新手 5 級 ‧ 2018-09-12 14:27:19 檢舉
不用下載 PHP 7就有包含 PDO跟mysqli
https://pjchender.blogspot.com/2015/08/php-data-objects-pdo.html
PDO開啟方法~

mysqli 我記得是不用特別去設定
直接用mysqli_connect(); 就可以了

不過如果是新學的話 學PDO吧 比較好用
了解,我在試試,另外請教第3行的localhost是指資料庫名稱嗎?還是?
柯柯 iT邦新手 5 級 ‧ 2018-09-12 14:53:58 檢舉
localhost 那邊是寫 你的資料庫 主機位置
你在本機 就是localhost~
70630515 iT邦新手 5 級 ‧ 2018-09-12 17:31:55 檢舉
我用的是5.4版寫的@@,請確認您的版本
感謝

1 個回答

0

意思是你的php程式是舊的,要改寫用mysqli or PDO,已經和匯入的資料庫無關…
不想改的話,就php降版吧

那請問目前最好用的是那一版本?

php 5.6 以後的版本吧,支援比較好,不過要說好用php 7還是效能最好

我要發表回答

立即登入回答