iT邦幫忙

0

請問一下.Net Framework

我想請問一下,
如果要安裝舊版的.Net Framework(4.0)有辦法嗎?
因為後面還有一大堆版本不可能一個一個刪再裝回去,
另外一個問題就是,
我看 程式及功能 裡面明明沒有裝 Framework 4.6.2 以上的,
但是它卻說我已經裝了而且不讓我裝...
不知道有沒有人知道如何解決,
謝謝~

看更多先前的討論...收起先前的討論...
Astair iT邦新手 5 級 ‧ 2019-06-21 15:11:54 檢舉
是win10嗎?
Windows10 如何查詢.NET Framework 版本
https://g2b-edoc.gcis.nat.gov.tw/g2b/download_att.php?dd=110
小魚 iT邦大師 1 級 ‧ 2019-06-21 15:43:23 檢舉
Windows 8
因為不小心砍到4.0,
偏偏有些專案又要用到4.0,
甚至連C++都說要用到.Net 4.0 XD
不過4.6.2確定沒有安裝,
清單中也找不到...
Astair iT邦新手 5 級 ‧ 2019-06-21 16:28:25 檢舉
https://www.filehorse.com/download-dotnet-framework-4/6023/

下載4.0裝看看呢?
Astair iT邦新手 5 級 ‧ 2019-06-21 17:05:49 檢舉
https://docs.microsoft.com/zh-tw/dotnet/framework/install/troubleshoot-blocked-installations-and-uninstallations

似乎無解了,裝了新的無法安裝更舊的,只能全部移除乾淨,再從最舊版本安裝

2 個回答

1
allenlwh
iT邦高手 1 級 ‧ 2019-06-21 15:05:34
最佳解答

是Windows Server嗎?

https://ithelp.ithome.com.tw/upload/images/20190621/20033493diZq5rLXeP.jpg

看更多先前的回應...收起先前的回應...
小魚 iT邦大師 1 級 ‧ 2019-06-21 15:47:13 檢舉

但就是沒有4.0可以選 XD
偏偏C++要用到.Net 4.0 XD

allenlwh iT邦高手 1 級 ‧ 2019-06-21 15:52:22 檢舉

直接安裝4.0,可以嗎?

小魚 iT邦大師 1 級 ‧ 2019-06-21 16:49:27 檢舉

如果可以,
就不用上來問了.

allenlwh iT邦高手 1 級 ‧ 2019-06-21 17:00:48 檢舉

有什麼錯誤訊息嗎?
只有這份文件可以參考了

https://docs.microsoft.com/zh-tw/dotnet/framework/install/on-windows-8-1

小魚 iT邦大師 1 級 ‧ 2019-06-22 16:06:26 檢舉

喔喔,
好像安裝了4.8版本之後就可以用了...

0
nansen
iT邦新手 3 級 ‧ 2019-06-22 10:09:36

.Net Framewrk 4的CLR版本都是一樣的
理論上只需要裝最後一個版本可以往前相容4.x

https://docs.microsoft.com/zh-tw/dotnet/framework/migration-guide/versions-and-dependencies

小魚 iT邦大師 1 級 ‧ 2019-06-22 15:48:31 檢舉

也是,
安裝了4.8版就可以用了.

我要發表回答

立即登入回答