iT邦幫忙

0

請問 vsCode 如何讓它不要自動出現背景色?

請問 vsCode 如何讓它不要自動出現背景色?
我只要把游標放在字元中間,
它就會自動在那一整串字元出現背景色,
但我選取字元的背景色跟它自動出現的背景色非常像,
造成我看不清楚我到底選了哪些字,
請問我要如何讓它不會自動出現背景色?
https://ithelp.ithome.com.tw/upload/images/20211130/20076058WWskRwzBtc.jpg
例如圖片中,
我選取 var 這 3 個字元,
但它會自動出現 $the_var_color 的背景色,
請問如何去除?
謝謝!

1 個回答

2
海綿寶寶
iT邦大神 1 級 ‧ 2021-11-30 11:44:51
最佳解答

關掉(uncheck)Occurrences Highlight即可

https://ithelp.ithome.com.tw/upload/images/20211130/20001787pnJOxF2Q16.png

vscode 完整的 highlighting
可以參考這篇

看更多先前的回應...收起先前的回應...
samjam iT邦新手 4 級 ‧ 2021-11-30 12:03:35 檢舉

謝謝您,解決囉!
另外想請問如果不想從設定進去,要自己改 settings.json,
我試了 "editor.occurrencesHighlight": false,
但沒效果,請問這應該如何設呢?
查到這篇相關的
https://github.com/Microsoft/vscode/issues/5351

settings.json 有三種
也許你改的不是你要的那一種

samjam iT邦新手 4 級 ‧ 2021-11-30 12:27:34 檢舉

我是改第一種的 in User Preferences (Global)

samjam iT邦新手 4 級 ‧ 2021-11-30 14:38:43 檢舉

不好意思,我發現原因了,
我之前把它設在

"workbench.colorCustomizations": {
    "editor.occurrencesHighlight": false
}

把它移出大括號外就可以了,
謝謝您!

我要發表回答

立即登入回答