iT邦幫忙

DAY 4
2

Cisco技術學習與實作系列 第 4

使用 packet tracer 淺玩 voice

voip 開機流程

1. 給電源

2. 藉由 CDP 從 Switch 那得到 voice vlan

3. 發出 DHCP Request 要求 ip 相關資訊,並 得知 tftp server ip ( option 150 )

4. 從 tftp server 那 下載一切需要的檔案 並得知 CME 的位置

5. 向 CME 註冊

===========

實驗環境:

CME Router 發送 相關的 voice information

實驗中 讓此Router 同時扮演 DHCP 、 TFTP 、 CME Server

此實驗中 只讓vlan 20 可以註冊至 CME , vlan 10 並無設定

vlan 10 為 data vlan : 172.16.0.0/24

vlan 20 為 voice vlan : 192.168.0.0/24

============================================

相關設定:

CME:

CME(config)#int fa 0/0
CME(config-if)#no sh
CME(config-if)#int fa 0/0.10
CME(config-subif)#en do 10
CME(config-subif)#ip add 172.16.0.254 255.255.255.0
CME(config-subif)#int fa 0/0.20
CME(config-subif)#en do 20
CME(config-subif)#ip add 192.168.0.254 255.255.255.0

## 以上 基本 介面ip 設定

CME(config)#ip dhcp pool data ## 因為 data vlan 沒設定 option 150 所以等等 cipc 無法註冊
CME(dhcp-config)#network 172.16.0.0 255.255.255.0
CME(dhcp-config)#default-router 172.16.0.254
CME(dhcp-config)#ip dhcp pool voice
CME(dhcp-config)#network 192.168.0.0 255.255.255.0
CME(dhcp-config)#default-router 192.168.0.254
CME(dhcp-config)#option 150 ip 192.168.0.254 ## 此為 tftp server ip 指為自己

## 以上是設定 DHCP

CME(config)#telephony-service ## 進入 cme 設定
CME(config-telephony)#max-ephones 4 ## 支援 最大電話數
CME(config-telephony)#max-dn 4 ## 支援最大號瑪數 這兩個都要看 CME 支援到多少
CME(config-telephony)#ip source-address 192.168.0.254 port 2000 ## 設定CME ip 而 cisco SCCP 預設使用 tcp 2000
CME(config-telephony)#auto assign 1 to 4 ## 自動 配發電話 1 到 電話 4
CME(config-telephony)#exit

CME(config)#ephone-dn 1 ## 定義電話號碼編號 1
CME(config-ephone-dn)#number 1001 ## 號碼 1001

CME(config)#ephone-dn 2
CME(config-ephone-dn)#number 1002

CME(config)#ephone-dn 3
CME(config-ephone-dn)#number 1003

CME(config)#ephone-dn 4
CME(config-ephone-dn)#number 1004

CME(config)#ephone 1 ## 定義 電話 1
CME(config-ephone)#mac-address 00D0.FFA4.BD72 ## 設定 mac 其指到 pda
CME(config-ephone)#type CIPC ## 類型
CME(config-ephone)#button 1:1 ## 第一個按鈕 對到 編號 1

CME(config)#ephone 2
CME(config-ephone)#device-security-mode none
CME(config-ephone)#mac-address 0002.1708.E154
CME(config-ephone)#type 7960
CME(config-ephone)#button 1:2

CME(config)#ephone 3
CME(config-ephone)#device-security-mode none
CME(config-ephone)#mac-address 0090.2120.3237
CME(config-ephone)#type 7960
CME(config-ephone)#button 1:3

CME(config)#ephone 4
CME(config-ephone)#device-security-mode none
CME(config-ephone)#mac-address 0030.F24C.4401
CME(config-ephone)#type ata
CME(config-ephone)#button 1:4

Switch0:

Switch#sh run

interface FastEthernet0/1
switchport access vlan 10
switchport voice vlan 20
!
interface FastEthernet0/2
switchport access vlan 20
!
interface FastEthernet0/3
switchport access vlan 20
switchport voice vlan 20
!
interface FastEthernet0/4
switchport voice vlan 20

## 使用 data vlan 和 voice vlan 的意義在於 服務品質 ,不過這次的實驗中並無此考量需求

## switch 需啟動 cdp 這樣 ip phone 才知道自己的 voice vlan

Phone1:

在 packet tracer 的設定中,需要接上電源,就可以了

ip phone 相當於一個小型交換器 拿實體出來時

COMPUTER PORT : 接PC

NETWORK PORT : 接Switch

AP & PDA:

AP 不用設定

PDA 設 DHCP 取得IP 即可

Home VoIP0:

手動設定預設閘道 192.168.0.254 即可

AnaPhone1 不用設定

===================

提供參考:

https://mega.co.nz/#!aQZHUD6D!SJHcJA14hR0YHm9Rbyxgsrh1-VDC1XrXcruikz\_8NCI

我的 packet tracer 是 packet tracer 6


上一篇
ip unnumber ( 借用ip )
下一篇
Router 當 DNS Server
系列文
Cisco技術學習與實作16

2 則留言

0
air20120116
iT邦新手 5 級 ‧ 2014-10-02 17:29:44

好詳細唷~

0
SoL
iT邦新手 4 級 ‧ 2014-10-02 22:42:31

謝謝

我要留言

立即登入留言