iT邦幫忙

0

網路磁碟機上執行軟體執行換成giga之後常常無法正常作業

小弟的軟體是放在SERVER開網路磁碟機共用,然後CLIENT端XP 是利用連線網路磁碟機去執行,目前20台連線到SERVER去作業

CLIENT端會灌安裝程式BDE 然後設定路徑去執行,最近我們公司把網路改成GIGA環境,接法是SERVER下來有一台16 PORT GIGA HUB

底下個接6各8PORT GIGA HUB到各個辦公室,改成這樣之後,我們系統常常會出現NETWORK 錯誤,但是對外連線卻都正常,

有時編輯系統一段時間後,要存檔就會出現 NETWORK 錯誤,但是當下去點網路磁碟機去都正常可以進入,也沒有瞬段情形,不知道是哪裡出了問題

真的是GIGA環境的問題嗎 有點類似網路延遲 我們系統登入者斷掉之後要在進入就會無法進入他會顯示已有相同使用者在裡面

請教大家有沒有解決方法 感激不盡

1.目前16PORT HUB 也更換過

  1. SERVER本來是2008 換成備用 2003 也是一樣問題

3.不知道是不是SERVER效能不夠

4.SERVER也更換過 INTEL 網卡 也不行

5.有將各個辦公室用VLAN切開 但是各個辦公室還是會不定期發生問題

看更多先前的討論...收起先前的討論...
CalvinKuo iT邦大師 7 級 ‧ 2013-11-08 17:29:30 檢舉
請檢查:
1. 伺服器事件檢視器有無IP衝突Log...
2. 瞬斷當下,ARP -A伺服器IP是否對應正確MAC...
CalvinKuo iT邦大師 7 級 ‧ 2013-11-08 17:31:44 檢舉
另外是不是只有BDE連線有問題,網芳與PING都正常的話。請朝BDE設定方向處理...
lt885 iT邦新手 5 級 ‧ 2013-11-08 17:41:29 檢舉
測試過沒有瞬段情形,但是軟體就是不常,bde也都是照舊設定 不知道是否改成giga之後哪裡要更改設定呢
iknowlab iT邦研究生 4 級 ‧ 2013-11-08 17:41:29 檢舉
既然懷疑 Giga Switch,就換回 10/100 switch看看。
PO 一下 Giga 的品牌型號供大家卓參。
lt885 iT邦新手 5 級 ‧ 2013-11-08 17:41:59 檢舉
ip也沒有衝突 每一台都有設定一個ip手動設定
lt885 iT邦新手 5 級 ‧ 2013-11-08 18:08:41 檢舉
ZYXEL 108S 我總共裝六台

2 個回答

6
raytracy
iT邦大神 1 級 ‧ 2013-11-08 17:50:41
最佳解答

原本用 10/100M 的 switch, 代表當初的佈線規格也是用 10/100 的線材, 現在換成 Gigabits Switch, 全公司的線材有跟著抽換成 Gigabits 的規格嗎?

看更多先前的回應...收起先前的回應...
lt885 iT邦新手 5 級 ‧ 2013-11-08 18:08:00 檢舉

有線路有重新佈線 主線都改成cat6

u8526425 iT邦大師 1 級 ‧ 2013-11-08 19:26:09 檢舉

在沒有專業線路分析儀的時候有兩種簡單的方式可以測線路

  1. ping -t
  2. 部份網路卡管理程式可以做簡易線路品質分析

當然
在你後面有edge switch分接的時候
這種方式是沒辦法告訴你問題是在哪一個節點

lt885 iT邦新手 5 級 ‧ 2013-11-08 19:51:15 檢舉

ping -t 都沒有斷 開整天測試都很好

lt885 iT邦新手 5 級 ‧ 2013-11-13 08:35:26 檢舉

有可能是你說的問題,我只是主線換成CAT6其他街道電腦端得沒有換
目前我改回10/100的switch run了3天目前正常感謝您
至於是不是線路問題等有機會全部換成cat6的時候再來找答案了謝謝

8
player
iT邦大師 1 級 ‧ 2013-11-08 19:05:06

WinXP的網路磁碟機, 有TimeOut自動切斷連線的問題
詳見KB297684 - 連線到網路共用的對應磁碟機可能已中斷連線

lt885 iT邦新手 5 級 ‧ 2013-11-11 09:45:37 檢舉

這個方法我有試過更新 但還是一樣
請問連線磁碟機有連線數的限制嗎
我是用2003SERVER

我要發表回答

立即登入回答