iT邦幫忙

0

python 無法安裝 googletrans

我嘗試安裝了這個googletrans但一直遇到問題

! pip install googletrans

https://ithelp.ithome.com.tw/upload/images/20210524/20136815u3pfcuVPoW.jpg

ERROR那邊說到找不到googletrans對應的發行版本

2 個回答

0
johnsonnnn
iT邦新手 5 級 ‧ 2021-05-24 09:33:44

pip install googletrans
https://ithelp.ithome.com.tw/upload/images/20210524/20123150UntqZ3bIiB.jpg
你多打了一個s
https://ithelp.ithome.com.tw/upload/images/20210524/20123150QVeOHLJ9jY.jpg

看更多先前的回應...收起先前的回應...

現在出現的是這個
https://ithelp.ithome.com.tw/upload/images/20210524/20136815pbcjJG3axG.jpghttps://ithelp.ithome.com.tw/upload/images/20210524/20136815nGZ7DG079H.jpg

你有相關依賴的安裝包沒安裝
試試
pip install pyqt5 pyqtwebengine pathlib ruamel-yaml

安裝出現這個

ERROR: Could not install packages due to an OSError: [WinError 5] 存取被拒。: 'C:\\Users\\sandr\\anaconda3\\Lib\\site-packages\\PyQt5\\QtCore.pyd'
Consider using the `--user` option or check the permissions.

pip install PyQt5==5.12.3 pyqtwebengine==5.12 pyqt5-tools pathlib ruamel-yaml --user

也安裝這個結果跑出這個QAQ

ERROR: Exception:
Traceback (most recent call last):
  File "C:\Users\sandr\anaconda3\lib\site-packages\pip\_internal\cli\base_command.py", line 180, in _main
    status = self.run(options, args)
  File "C:\Users\sandr\anaconda3\lib\site-packages\pip\_internal\cli\req_command.py", line 204, in wrapper
    return func(self, options, args)
  File "C:\Users\sandr\anaconda3\lib\site-packages\pip\_internal\commands\install.py", line 318, in run
    requirement_set = resolver.resolve(
  File "C:\Users\sandr\anaconda3\lib\site-packages\pip\_internal\resolution\resolvelib\resolver.py", line 127, in resolve
    result = self._result = resolver.resolve(
  File "C:\Users\sandr\anaconda3\lib\site-packages\pip\_vendor\resolvelib\resolvers.py", line 473, in resolve
    state = resolution.resolve(requirements, max_rounds=max_rounds)
  File "C:\Users\sandr\anaconda3\lib\site-packages\pip\_vendor\resolvelib\resolvers.py", line 384, in resolve
    raise ResolutionTooDeep(max_rounds)
pip._vendor.resolvelib.resolvers.ResolutionTooDeep: 2000000

謝謝您的幫忙~

0
I code so I am
iT邦高手 1 級 ‧ 2021-05-25 09:39:42
  1. Google API 已改變,但googletrans套件沒有隨之修改,需安裝舊版。
    pip install googletrans==3.1.0a0

  2. [WinError 5] 存取被拒 --> 先結束所有Python程式及 Jupyter Notebbok,再安裝套件。

了解了!謝謝您~

我要發表回答

立即登入回答