iT邦幫忙

0

OUTLOOK2007寄出的信附加檔變成winmail.dat

OUTLOOK2007寄出的信附加檔變成winmail.dat
附加檔包含pdf ,ZIP 都一樣到對方都變成winmail.dat,只是用outlook2007沒使用exchange SERVER,爬過一些文說寄時要用html不可用rtf格式,這些都試過了都還是不行

jamesjan iT邦高手 1 級 ‧ 2008-12-24 17:34:50 檢舉
我沒有使用 Outlook 2007
不過在網路上找到一篇文章供您參考

http://arrowquick.com/articles/dealing-with-winmail-dat-problems
cathy6270 iT邦新手 5 級 ‧ 2012-03-08 09:56:23 檢舉
http://support.microsoft.com/kb/958012/zh-tw

在這情況,微軟總算發表示修改程式
在這請各位大大們參考..
....真是害死我了...
害我黑的發亮~~~~
cathy6270 iT邦新手 5 級 ‧ 2012-03-08 09:58:05 檢舉
改完後 從此不用逼客戶 不用逼USER~
只是 要一台一台改過~~
認命吧~~總比之前情況好太多了........
40
hpc
iT邦新手 4 級 ‧ 2008-12-24 14:26:27
最佳解答

原因是 :
寄件者在寄出信件時,使用Outlook設定信件格式為「使用 Outlook Rich Text (RTF) 格式傳送」。
導致利用非Outlook收信的人,看到寄來的信件所夾帶的附檔是「winmail.dat」。

由於 Microsoft 的 Outlook 會將Mail 使用 RTF 格式送出,所以只要使用非 Outlook 的讀信軟體,就會看到一個 winmail.dat 的附件(使用Live Mail則連winmail.dat的附件都看不見) ,完全看不到信件的內容。
解決方法 :

請寄件人調整Outlook發信的信件格式後,再重寄一次。為避免自己寄出的信件,也造
成別人的困擾,也可調整自己的設定。

打開 Outlook,到「工具」→「選項」→「郵件格式」,選為「轉換成HTML格式或純文字格式」都可以, 不要選擇「使用 Outlook Rich Text (RTF) 格式傳送」。
關於Outlook winmail.dat問題參考

看更多先前的回應...收起先前的回應...
julie8tw iT邦研究生 4 級 ‧ 2008-12-24 14:30:38 檢舉

已經說過確認是選HTML

hpc iT邦新手 4 級 ‧ 2008-12-24 15:21:07 檢舉

請看 我後面補充的連結 關於Outlook winmail.dat問題參考
裡面寫到

解決方法 2:

利用一些程式在讀取 winmail.dat 的內容,如 Winmail Opener 或 Winmail.dat Reader 這樣的軟體,可以把 .dat 的檔案,關連到這類的程式。

希望能解決你的問題

hpc iT邦新手 4 級 ‧ 2008-12-24 15:27:05 檢舉

還是有問題的話,歡迎討論,也可以寄一封測試信給我,幫你測試看看

我今天早上才剛幫我們User解決這跟你同樣的問題

來自國外的客戶寄來的E-Mail問題,看不見當中包含的附件
http://ithelp.ithome.com.tw/question/10015585
http://ithelp.ithome.com.tw/question/10015495

hpc iT邦新手 4 級 ‧ 2008-12-24 15:41:04 檢舉

注意喔 !! Outlook 設定
打開 Outlook,到「工具」→「選項」→「郵件格式」,

點選 "網際網路格式" 按鈕,選「轉換成HTML格式或純文字格式」都可以,
不要選擇「使用 Outlook Rich Text (RTF) 格式傳送」。

要點選 "網際網路格式" 按鈕裡面的選項也要改成 HTML 喔!!!! 不要只改外面的HTML唷

julie8tw iT邦研究生 4 級 ‧ 2008-12-24 16:47:48 檢舉

感謝 hpc的幫忙! 只是我跟你是相反,我這邊是user寄給外面廠商,出現的dat,外面廠商沒有it,用啥軟體搞不清楚,我猜是outlook express,故請廠商用軟體去讀dat根本是不可能的事,一句話微軟惹的禍!

hpc iT邦新手 4 級 ‧ 2008-12-25 08:46:16 檢舉

沒錯,是微軟惹的禍!!
不過我倒是很想知道你實際會發生這樣問題的原因
我們收發信,現在都沒用outlook了,
但許多國外的客戶,都還是用outlook收發mail
我們也沒辦法去要求廠商或客戶更換軟體,甚至更改設定
所以e-mail之間的相容問題,一直都很傷腦筋

建議你朝幾個方向研究解決問題

1.防毒軟體是否干預掃描收發Mail
2.outlook 2007 移除乾淨,重新安裝(記得先匯出備份通訊錄及信件)
3.寄一封測試信給自己,及其他信箱用不同收信軟體收看看(可以寄一封給我,幫你看看)
4.MailServer是哪一種? 能否自己調整設定?
5.以上都沒辦法解決的話,換一套Mail軟體吧

30
tom6507
iT邦大師 1 級 ‧ 2008-12-24 11:12:25

因為是對方的mail server轉碼錯誤,跟你無關

julie8tw iT邦研究生 4 級 ‧ 2008-12-24 14:30:08 檢舉

如果可以這樣回應USER我也想要

26
glennlin
iT邦研究生 4 級 ‧ 2008-12-24 11:13:39

你的電腦上則能夠在郵件格式的網際網路格式中設定outlook rtf選項
選擇-轉換html格式
這樣比較能夠避免winmail.dat產生

julie8tw iT邦研究生 4 級 ‧ 2008-12-24 14:29:45 檢舉

我的問題上面已經寫了我是選HTML格式

30
ycl8000
iT邦高手 1 級 ‧ 2008-12-24 18:14:22

1.可以試試看這套免費的軟體, 專門用來開啟 winmail.dat.
http://www.eolsoft.com/freeware/winmail\_opener/

2.我公司用的MAIL SERVER軟體裡頭有一個選項:
將MS-TNEF格式的郵件轉成MINE格式, 開啟這個選項後,
就不用擔心收到的信變成winmail.dat.

20
ctc242
iT邦新手 5 級 ‧ 2008-12-24 23:47:23
  1. 可以先關掉防毒嗎?
  2. 寄封信加附件給自己也是如此嗎?
  3. 只有單一user的Outlook 2007 這樣? 整個Office移掉再重裝呢?
  4. Outlook 2007 -> Outlook Express (Windows Mail)也會嗎?
  5. 知道Mail server是?
34
shadowpeople
iT邦新手 1 級 ‧ 2008-12-25 09:23:04

這個問題小弟也在前一陣子遇過,差點沒被搞死,不過有找到下述解決方式

  1. 環境:Windows XP + Office 2007,Mail Server 非 Microsoft Exchange Server。

  2. 解決方式:
    A. Client Outlook 寄件格式必須設定為 HTML or TXT。
    B. Client 電腦透過"開始"→"執行"→"輸入 regedit 按確定"在下述登陸檔路徑增加一筆登陸檔數值「名稱」=DontEncodeCustomNote、「數值類型」=dword、「數值」=00000001。
    登陸檔路徑=HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Mail
    C. 重新啟動電腦。

  3. 原因說明:目前所知,因為機車微軟改了兩個模式,除了 Outlook 夾帶 Microsoft Office 系列的文件會自動變更成 RTF 格式信件外(RTF信件為微軟獨規),於寄信的模式還是會採用 RTF 方式進行信件投遞,所以得透過修改登入檔的方式強迫信件投遞一定要採用一般規範的 TXT 模式(就是上述修改登陸檔的方式),才能讓其它收信軟體辨識(如OE6 or Other)。

  4. 注意事項:
    A. 一定要正確的關閉使用中的 Outlook(當信件的PST檔過大時,關閉Outlook需要很久的時間)以及其它視窗再進行修改(建議第一次啟動電腦,為開啟任何視窗時就修改,因為Outlook2007曾發生過雖然看到是關閉了,但是仍然常駐於記憶體中,這樣子就會修改不順利)。
    B. 小弟或許太笨了,不過這種方式套用在 Vista + Office 2007 時,曾經技術指導同事修改卻發生失敗的例子(因為也僅有那一台可以讓小弟修改,且無法開啟遠端連線控制的情況下,相當不瞭解同事的修改動作是否正確),如果有網友修改成功麻煩回一下文,讓大家分享一下,在此感激不盡。
    C. 如果這個方式修改後,還是無法解決信件變成 winmail.dat 的話,依據原文(說到這個真的是見鬼了,因為這個解決方式僅有微軟日文網站小小一篇,其它英文、繁簡中文都找不到)的說法,就是無解了下述貼上原文的解決方式供大家參考。
    現象:
    Microsoft Office Outlook 2007 でメッセージを送信した場合、メッセージの受信者には次のような現象が発生することがあります。
    メッセージに Winmail.dat というファイルが添付される
    送信時に添付したファイルが削除される
    送信時に添付したファイルが削除され、Winmail.dat というファイルが添付される
    原因:
    Outlook 2007 では、送信者が使用した書式を保存し、Transport Neutral Encapsulation Format (TNEF) 形式でエンコードしたものを winmail.dat として送信します。受信側の電子メール クライアントで Winmail.dat ファイルが認識されないことが原因でこの問題が発生します。
    解決方式:
    方法 1 : 送信する電子メール形式を変更する
    送信するメッセージの電子メール形式を変更し、リッチ テキスト形式を使用しないように設定します。設定方法については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    830302 (http://support.microsoft.com/kb/830302/JA/ ) 電子メールの添付ファイルが一部の受信者に表示されない
    方法 2 : レジストリでエンコードを設定する
    警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。
    [スタート] ボタン
    元に戻す画像を拡大する
    をクリックし、[検索の開始] ボックスに regedit と入力し、Enter キーを押下します。

元に戻す画像を拡大する
管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。
レジストリ エディタで次のレジストリ キーを見つけます。

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\12.0\Outlook\Options\Mail
[Mail] を右クリックし、[新規] メニューの [DWORD (32 ビット)] をクリックします。次に DontEncodeCustomNote と入力します。
DontEncodeCustomNote をダブルクリックし、値を 0 から 1 に変更します。
[OK] をクリックします。
レジストリ エディタを終了します。

julie8tw iT邦研究生 4 級 ‧ 2008-12-29 09:33:35 檢舉

不好意思你下面那段REGEDIT 是乎跟上面無關吧! 下面那對是"元に戻す画像を拡大する"

20
brucecheng
iT邦新手 3 級 ‧ 2008-12-25 09:37:34

小弟之前公司有遇上此問題,當然大多數解決方式(包含微軟)都是叫我們將傳輸文件格式不要選RTF,但在OUTLOOK2007似乎仍是有此問題,如同SHADOWPEOPLE所說。

您要不要試著將文件格式選用純文字(TEXT)寄看看,若成功,麻煩告知一下。目前敝司沒在用OUTLOOK 2007,也沒有測試版,可以替您試試,SORRY。

julie8tw iT邦研究生 4 級 ‧ 2008-12-26 17:08:25 檢舉

可以回應你 設成txt and html 對方端還是有問題! 原因不明

26
davidliu9116
iT邦研究生 3 級 ‧ 2008-12-25 10:16:58

這個問題已向台灣微X反應多次.
這是Outlook系列的通病,基本上無解.
1.不是Mail Server的問題.
2.問題延續多年.So 如果能解決早已解決了.
3.就算你設定了HTML格式,依然會有發生的情形,只是機率降低而已.

台灣微X給我的回覆是:
1.請對方改用Outlook(想也知道...不.可.能).
2.用非Outlook的Mail軟體再發一次該封信.

P.S.不能委屈別人就委區自己人吧,全面改用非Outlook的Mail軟體收發信就沒問題了.
不過很難成功,用過Outlook的人很難戒的掉.

julie8tw iT邦研究生 4 級 ‧ 2008-12-29 09:26:37 檢舉

感謝你的回覆,我目前的處理方式就是真對那些廠商,請USER用非OUTLOOK軟體再發一次信,只是不知道要怎跟USER解釋,應該覺得我很遜吧! 隨便+無奈!

我要發表回答

立即登入回答