iT邦幫忙

0

[已解決]vSphere 6.0 連Server 2012 R2 iSCSI MPIO速度不理想問題

環境
Dell Nx3230
Server 2012 R2,4張Intel 4P I350-t 1G網卡,
2張做MPIO 10.1.10.70/10.1.10.71,分配10T做iSCSI 完整空間配置

Dell R730
vSphere 6.0,4張Broadcom 5720 1G網卡,已更新最新網卡驅動
2張做MPIO 10.1.10.65/10.1.10.66

Cisco 2960X 2台間設Etherchannel
vSphere iSCSI MPIO設定參考
http://www.vkernel.ro/blog/configuring-iscsi-multipathing-mpio-in-vmware-vsphere-5
https://ithelp.ithome.com.tw/articles/10135271
2012有安裝Multipath IO並設定MPIO 新增iSCSI裝置的支援
vSphere vSwitch0 建MPIO1、MPIO2(各1張網卡up 1張down)
軟體式iSCSI 探索2012 2張網卡IP,綁定2張網卡
嘗試
2012網卡1、2與vSphere網卡1、2全接在同1台交換機或
2012網卡1、vSphere網卡1接到交換機A,2012網卡2、vSphere網卡2接到交換機B
結果都不如意,看起來是負載平衡只吃1G如圖,不知該如何調校
交換機有沒法只針對特定端口開9k?因還有接其他設備
https://ithelp.ithome.com.tw/upload/images/20181003/20094721cGw8HKy91J.png
https://ithelp.ithome.com.tw/upload/images/20181003/20094721Keh6vejQGr.png
下圖多了2個路徑是他連去2012別的IP產生的,關了或開著測試沒影響
https://ithelp.ithome.com.tw/upload/images/20181003/20094721hj5HMjbeTn.png
File Server本地測速
https://ithelp.ithome.com.tw/upload/images/20181003/20094721iIShmsS8yG.png
GuestOS掛載後測速,積極歸零,GuestOS 完整格式化
https://ithelp.ithome.com.tw/upload/images/20181003/20094721wdRvHnBVkZ.png

1 個回答

1
raytracy
iT邦大神 1 級 ‧ 2018-10-03 11:52:44

你有了 MPIO, 為何 Switch 上面還要啟動 LACP?
您貼的第二個網址, 不是說 LACP 不適合 iSCSI 了嗎?

看更多先前的回應...收起先前的回應...
vicentli iT邦新手 3 級 ‧ 2018-10-03 12:39:26 檢舉

雷神大您好,因為公司所有Server都接在這2台交換機下,有做其他服務,所以交換機之間才有設Etherchannel。若做MPIO網卡都在同一台交換機是否就不受LACP影響?試了全接在同一台交換機沒改善。

raytracy iT邦大神 1 級 ‧ 2018-10-03 16:14:17 檢舉

您這邊怎麼設定?
Status 是否兩個都 Active?

vicentli iT邦新手 3 級 ‧ 2018-10-03 17:55:58 檢舉

雷大您好,如第三張圖,我是設定循環配置資源,Status全部作用中(I/O)。晚上我用另一台Server 2012 雙網卡掛這台的iSCSI 測試好了,感謝雷神前輩

vicentli iT邦新手 3 級 ‧ 2018-10-03 23:48:42 檢舉

測完2台Server 2012 雙網卡MPIO可跑到180~200M
肯定是我的vSphere設定上有問題,明天白天再重做一次
謝謝

vicentli iT邦新手 3 級 ‧ 2018-10-05 11:35:35 檢舉

解決了,我的管理路徑裡 如發文的圖裡有6條,先前停掉非MPIO的IP只留下4條與MPIO IP有關的。但看雷神前輩的圖只有2條,我就再停2條,就可以跑150M以上了。我原以為vsphere 2張網卡對2012 2張網卡2x2要有4條路徑才沒去動

vicentli iT邦新手 3 級 ‧ 2018-10-08 20:58:56 檢舉

過了幾天,測速又低迷了,但GuestOS用CentOS,用hdparm 及 先dd一個1G檔案,放/dev/sda1(datastore) 丟到/dev/sdb1(file server iscsi)卻很快,搞不懂啊!不知有沒可以直接對vsphere測掛起來的儲存區速度的方法?

vicentli iT邦新手 3 級 ‧ 2018-10-08 21:01:20 檢舉

過了幾天,測速又低迷了,但GuestOS用CentOS時,hdparm及 先dd一個1G檔案,放/dev/sda1(datastore) 再丟到/dev/sdb1(file server iscsi)卻很快,搞不懂啊!我直接在vsphere cli用time+dd測也很慢,還有沒其他方法可以測嗎

vicentli iT邦新手 3 級 ‧ 2018-11-12 16:37:38 檢舉

解決了!參考這篇
http://blog.51cto.com/zhangsir/1025539

我要發表回答

立即登入回答