iT邦幫忙

2018 iT 邦幫忙鐵人賽
DAY 4
0

有時候可以把confluence想像成windows的作業系統,而有很多的軟體公司會開發各自的軟體,也包含著微軟自家的軟體,來安裝在Windows的作業系統上,也因為windows有多個版本,從一開始的windows3.1,windows95,windows98,windowsme,windowsxp,windows2000,.....一直到現在的win8,win10等作業系統,當我們要將軟體安裝在作業系統上的時候,就需要確認此軟體支援那些作業系統及需要哪些的執行環境,例如它可能需要framework4.0以上才可以執行;同樣的confluence也有多個版本,例如我剛開始接觸的4.1.2,5.8.2及目前最新的版本6點多的版本,而它也有很多plugin在support它的功能,當然每個plugin有其所支援的版本,也因為他有這樣的特性,當我對某個問題遇到無法解決的時候,在plugin的store中可以碰碰運氣(官方位址在https://marketplace.atlassian.com ,而我是把它當成一個軟體市場,裏頭有各家各式的功能,端看您找軟體的的關鍵字應用來找出您想要的),看看有沒有找到類似的plugin或是它對應的support服務,或許可透過這樣的方式來解決我工作上所遇到的問題。
我以我曾經遇過的幾個情況來整理分享,例如要如何在confluence建立投票系統來給使用者使用呢?而通常第一個反應會是輸入關鍵字:survey or feedback,結果有找到一個Multivote for Confluence的plugin (https://marketplace.atlassian.com/plugins/com.tngtech.confluence.plugin.multivote/server/overview),也可以看出此PLUGIN所支援的版本、是否需要費用、有哪家公司來開發.....等資訊。
https://ithelp.ithome.com.tw/upload/images/20171208/20003705Tnz199kRQt.jpg
而這之間當我看到免費的plugin,當下第一個反應會覺得開心,但當我看到下列的幾個地方,更讓我可以用興奮來形容,其一是線上討論區,而如果您發現最近的幾篇討論日期在最近1-2個月內,或許可以推論此PLUGIN有一定的使用者及support團隊在維護
https://ithelp.ithome.com.tw/upload/images/20171208/20003705PnOxsu2eus.jpg
而當您在support頁籤下有看到Email vendor / Submit a support request這樣的字眼時,這簡直就是棒透了,只要跟投票有關的應用,像是page的評比應用 (給幾個燈來判斷這篇文章的火紅程度),雖然不一定有答案,當我一定會試的寄信給元件作者,或是開個ticket來追問下去,這樣免費可以問得資源得來不易,需要妥善地來應用,而如果有所回應且有不一樣收穫的時候,只能說是自己賺到了,這個服務我是強力推薦的。
https://ithelp.ithome.com.tw/upload/images/20171208/200037055QoyxSuXYT.jpg
而至於開發元件的公司,則是可以看出這家公司有哪些的PLUGIN可以使用,以TNG Technology Consulting GmbH來說,則是有下列的plugin可以研究,而我們可以善用每家plugin對應的support email,或許我們可以透過這樣的聯繫
問到額外的應用資源來幫助自己更加成長
https://ithelp.ithome.com.tw/upload/images/20171208/20003705NKsFKQ7cOf.jpg

但在這裡分享一個與plugin原廠聯繫的處理過程,原廠有些時候並不會回覆較舊版本的使用問題,而雖然您的confluence版本可能只適用安裝舊版本的plugin,而或者是因為為了使用免費版本的關係,因而選擇了較舊版本的plugin,那麼將有可能沒辦法獲得原廠的support,分享案例如下:
因為要做出階層式space的呈現方式,找到SubSpace Navigation for Confluence,但是這個plugin在2.2版之前是免費的,在3.0後的版本是要付費的
https://ithelp.ithome.com.tw/upload/images/20180115/200037053dVyGO43hP.png
而目前我是選擇使用2.2版的免費plugin,但是在客製化階層sub space的時候,想與原廠來確認卻得到下列的回覆

unfortunately I have to inform you that the version up to 2.2.2 is no longer supported. A further development of the old versions has been discontinued. We are happy to help you with the current version. You can download it here: Download .
Further information on version 3.1.1. can be found here: Manual.

上一篇
Day3-資源的應用
下一篇
Day5-練習安裝Confluence
系列文
Confluence 線上協同作業之平台30

尚未有邦友留言

立即登入留言